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1 What Is OPC?

OPC (OLE for Process Control) is a standard designed for real-time data exchange between a
software application and process control devices such as PLCs. OPC defines an interface
independent of the device type. As a result, the end user is almost not limited in the choice of
hardware and software for his/her application. The only requirement is OPC compatibility.

There are two kinds of OPC components: OPC client and OPC server.

An OPC client is a program that gets (reads) the data from an OPC server for further
processing. The typical examples are MMI and SCADA/HMI systems.

An OPC server is a program that provides data to OPC clients. It is usually designed to read
data from a specific hardware device. An OPC client communicates with an OPC server
through a strictly defined interface. As a result, any OPC client can communicate to any OPC
server regardless of the type of device for which the server has been created.

The OPC standard is developed by the OPC Foundation organization grouping hundreds of
software companies and hardware manufacturers worldwide. New features are continuously
added to keep the standard up to date.

A tutorial demonstrating the basic aspects of the OPC standard is available on the website of
Matrikon, a renowned OPC product developer company.
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n Data Transfer Principle

1.1 Data Transfer Principle

OPC server is usually a MS Windows application that communicates with a HW device (PLC)
via device-specific protocol - server can communicate with HW device e.g. via serial line. Data
acquired from HW device is provided via unified interface to other applications - OPC clients.
OPC standard states, that several OPC clients (even from different companies) can connect to
an OPC server concurrently. Most OPC clients (like Reliance) can connect to several OPC
servers simultaneously.
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OPC Server Configuration n

1.2 OPC Server Configuration

OPC server is usually not provided only by HW device manufacturer, but also by other
companies, so several OPC servers can exist for a device. The list of OPC servers for a specific
device can be located on the OPC Foundation WWW pages.

After successful installation of an OPC server so called configuration have to be created and
registered. To create the configuration means to define the list of devices connected to the
OPC server, to define parameters of these connections and to define the list of tags (OPC
items) that should be read from the device. Configuration have to be saved and registered, so
it can be loaded immediately after OPC servers starts.

Note: OPC server installation, start and configuration is specific for every OPC server GUI (it is
OPC server producer specific).
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2 Reliance and OPC

Reliance is a modern SCADA/HMI (Supervisory Control And Data Acquisition) system
designed for monitoring and controlling industrial processes. One of many features of the
Reliance system is in-build OPC interface - Reliance is an OPC client.

The goal of this document is to describe steps required to create a simple visualization
project (application) connected to an OPC server.

Creating a New Visualization Project

Creating a New OPC Device

Connecting New Device in the Project Structure Manager
Adding a Display Component to a Visualization Window
Creating a Link to the Display Component

Running the Project in a Runtime Software

For detailed information about the Reliance system, please visit www.reliance.cz.
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Creating a New Visualization Project

2.1 Creating a New Visualization Project

To create new visualization project, start the development environment Reliance 4 Design
and select the File > New Project command.

« Reliance 4 Design - Project

File' Edit View Managers Project Tooels Window Help

ﬂ Mew Project... |
Open Project... Ctrl+Q |

Restore Project from Backup...

Close Project

Mew Window...

Mew Window Template...

Save Window Ctrl+5
Save All Windows

Close Window Ctrl+F4
Close All Windows

1 4 :hbaisas ¥3950 Projects\Projectl\Projectl.rpd

25 st el et AirCondition.rpd
B S

B IR, I,

Exit

File menu
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n Creating a New Visualization Project

Enter a name of the new project (e.g. OPC) on the Project name and location page of the
Create New Project Wizard. Change the default project directory if it is required and Finish the
wizard (on the next pages keep default settings).

Create New Project Wizard s

Project name and location E

Choose a name and location for your project.

Ewvem vizualization project iz stored in files organized in a directon structure. One of the files
haz an ".rpd' extension and iz called the main file of a project. [tz name iz generated bazed on
the name that vau enter far your visualization praject. The file name can cantain only characters
wUE e 0 Y and

Praoject Froject1.ipd

Chooze the directary where pour project should be stored.

(i Qg S e e s

Mate.: & new folder for the project will be created in the specified directon. The default
directony for vizualization projects can be configured through the Ervironment Optiong dialog.

¢ Back ] | M et >

Create New Project Wizard
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Creating a New Visualization Project

After a new project is successfully created, Create New Window Wizard automatically starts to
assist in creation of the visualization window. Visualization window contains graphical
elements (so called components), which define custom graphical user interface. On the first
page of the wizard enter the Name and the Title of new window (or keep the default settings).
Finish the wizard (on following pages keep default settings).

B asic information
Enter a name and title for the vizualization window.

Enter a name for the vizualization window. The name must be unigue within the project.
W indo ]

Enter a title for the visualization window,
Window

Cancel

Create New Window Wizard
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n Creating a New OPC Device

2.2 Creating a New OPC Device

Open Device manager via Managers > Device manager. Add a new OPC device with the New
Device command (in the Select Device Type dialog window choose OPC). Select the device
object in the upper left pane (in the tree) and configure the properties of the OPC device (on
the left side of the window). On the Basic page define the OPC server identifier (OPC server
Prog ID). The identifier can be entered either manually, or selected from the list of OPC

servers installed on your system (after clicking the OPC icon).

i3] Alarms/Events

i bl
& Device Manager —— [=][=] =]
2 Hm 7&. » Ei ‘E,], ? R By B azic |Advanced | Infarmation
-1 [0 Devices Name
I + j System orct
= % 98F oPC1
(& Tags Alias

Miscellaneous
OPC gerver Prog ID

9%F | X |TECO.DAZ

OPC server GUID
{A42F19F4-608B- 1414 e At ady

[ Import tags from remote compter

[ &utomatically generate OPC kemlD For nested tags

Liclicuikes

I ame

D=1 Devices\OPCT

- [ @ Select OPC Server =TSR
ags
(&) Alarms/Events OPC Server 0a1.0 Dazo
=) j Local
& Teco OPC Server es

L. Remote

|
oK ] [ Canecel ]
[ ok || oese || saves

Device Manager - Select OPC server dialog

I Reliance 4 - OPC Tutorial




Creating a New OPC Device n

In the tree select the Tags folder of the OPC1 device. Create a new OPC group via the New
OPC Group command (from toolbar or local menu). You can change its name for example to
OPC. Select the newly created folder object and via the Import from OPC Server command
import tags (OPC Items) from the OPC server - installed OPC server should automatically start
to provide the list of tags defined in its configuration.

G
@ e it

e

Address

)
v
]
H
]
H
L] R 5
§ O s Soadioosses
(3] Alarms/Events
+- & System
Mame Tupe
il Bool
Word (16...
Bool
¥ Word (15...
§ A Word (16...
¥ @ wupwmed Tosmat Bool
¥ § riswpad Mauehed Bool
[ 1D=1 Devices\OPCIAT agz\Groupl

[ & Device Manager _‘_ @E&J
im0 % L E T T -
= Devices Name
= w Alias

Export and import in C5¥ format

l

]l Expart [Unicode) ] [ Irnpart ]

Import of tags

Irnport from OFC Server ]
Import from DFC CSY |
Expoit to DFC C5Y |

Update interval [ms)

0OPC group properties

Dead band [%)

OPC group properties

500 0 = I
i

0OPC group state

) Inactive

@ Active

) Tag contralled

| |
ok || Cese || Savear |
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Creating a New OPC Device

The Import Tags from OPC server dialog window is divided into a left pane with Reliance
defined objects and the right pane with OPC server defined objects. Drag and drop objects
from right to left pane with a mouse to import the tags form the OPC server.

& Import Tags from OPC Server b @Mw
I]E Lol 3 i W | 2| B Empty/Defau - R/W - ¢
OPC Device OPC Server
Mame a Type Update interval | Mame - Walue Type Rt
E}"‘g: opPC1 EI--? TECO.D&2 OpPCc .. -
B & Tags Bl @ NSt S Bodl AW F
£ 5 Group] 500 Word .. Rw
: Baol i Bool AW
word (16 b) '3 Word... Rw
Bool - @ Wword .. R
L. Word [16b) - @ Baol R
whord (16 b) - @ Bool R
Bool v Longl.. Fiw
i Boal v T Longl... RWw
/K Longl...  Fw
Iy Fi Amray ... Fw
i Longl... Rw E
v Longl.. Rw
- i Longl...  Fw
i Date.. AW
@ Small... Rw
@ Bool R
@ Word... Rw
I @ Baol R
| @ Word .. R/
- @ Word ... R
I Boal R
@ ! Bool R B
v Longl...  Rw
B @ § Longl...  Rw
B v Longl.. Rw
-- [+ Aray ... Fw A
m 4 | mamml =YX}
[ ] J ’ Cancel

Import Tags from OPC Server dialog
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Connecting a New Device in the Project Structure Manager

2.3 Connecting a New Device in the Project Structure Manager

Each object that should be accessed on runtime have to be connected to a computer first.
Connecting an object to a computer means to add an object to a specific folder in the Project
Structure Manager under required computer (configuration). After the changes made in the
Device Manager are saved, the user is asked if newly created object should be connected to
the computer. If Yes is chosen, Project Structure Manager is automatically opened and OPC
device is added to the Devices folder under the PC1 computer. If No is chosen, object is not
connected to any computer and it have to be connected later manually.

Before a device is connected, first open the Project Structure Manager (Managers > Project
Structure Manager) and in the left pane (the tree) select the Devices folder. To manually
connect a device to a computer chose the Connect Devices command from the local menu (or
Connect Objects from toolbar).
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Connecting a New Device in the Project Structure Manager

Project Structure Manager ' -‘“_x ;E

i h % h:- Z [} e e Ex 4 B x| Basic | MEM file | Information
B- Gil Control Areas Enable
= % Control Areat .
il | Onl
ey & ot rlire
= Devices Active channel choice
= Q Automatic
% Channelt Tag-controlled [Index)
- [i@] Data Tables
- (il Trends [ Index | | X |— |
- [ Reports
- [Z custom Reports [ Status | |>K |_ |
. Recipes
- [ seripts Channel list
- [ Users
(%% Printers 4 % Order
- [§E] Modems & Channel
&} @ Communication Drivers
(&) Server Connection Groups
% Channell
+ 1 | »
D=1 Contral Areas\Cantrol Area14PCT\Devices\OPCT Lok J[ oee J[  sses |
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Connecting a New Device in the Project Structure Manager

In the Select Device dialog window chose OPC1 device and confirm.

& Select Device

S5

OPCA

L ‘u"iew ~ Manager

[tem hst

Ok

|| cancel

D=1 OPC1

Select Device dialog

Close Project Structure Manager with the OK button to save the changes.
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Adding a Display Component to a Visualization Window

2.4 Adding a Display Component to a Visualization Window

The Display component is located in the component palette (to the right from the main menu)
on the Standard tab. Select the Display component in the component palette and click into
the visualization window area to add the component.

Window Help Standard | Teco | Johnson Controls ' Sauter | Vectors = Co
80 sz oo ceaye NEAESAABBUTE =
p g | ML T R & 5
F‘H‘H’indcwl - Window1 o o= S

Adding the Display component to a visualization window
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Creating a Link to the Display Component

2.5 Creating a Link to the Display Component

Newly added display component have to be linked to a tag to show a value. Open the Display
Properties dialog (e.g. double click on the component or select the command from the
component's Local menu).

‘ d Align Position to Grid
\ 18 Align Size to Grid
E] Lock Ctrl+L
[l Save Window Ctrl+5

Duplicate Window...
Close Window

Component Properties... Alt+Enter

Component's Local Menu
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Creating a Link to the Display Component

On the Functions tab enter tag's full name in the Link to tag field. Tag name can be also
selected via Select Tag dialog (dialog is shown after the icon on the left is clicked).

Display - Properties

| Basic I.-'-‘-.Iignment | D_I,Inamicl hderu I Scoriptzdtctiong | Securit_l,l| Functions |Stati|: | Eng. units|

Link to tag

Test value 0.00
Limitz
[] High warning [] High critical

" alue Walie

B ackground Background .

[] Low warning [7] Low critical

W alue Walle

B ackground Background .

k. ” Cancel l Apply

Display Properties
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Creating a Link to the Display Component

In the dialog window select the tag imported from the OPC server (see chapter Creating a new
OPC device) and confirm the dialog with the OK button.

r‘ Select Tag . X
¥ T % @Wm - Manager L ~

Kotelnal.Cerpadio

Tag Type Address

Bool M:me e
Word (16 b) el Mgy
Bool Suhariead Mg

ak. ] ’ Cancel

ID=1 OPCTMGroup!'dasims® B i

Select Tag dialog
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Running the Project in a Runtime Software

2.6 Running the Project in a Runtime Software

To start the project in the runtime software select the > Project > Start command from the
main menu (or press F9). The type of started runtime software depends on the licence and on
the settings in the Project > Options > Runtime (View, Control or Control Server).

Managers Project Tools Window Help

= B (E T 3
E o ﬁ Create Shorteut... I
———— $ Perform Diagnostics...

i‘-. Backup...

## Export for Remote Users..,
Starting the runtime software

The display component shows the real-time value of the OPC tag.

¢ Reliance 4 Control Server - OPC - PC1

File Help

50l BB

10

Tag value displayed in the Display
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